emath saloon (Read Only)

新規発言一覧最新記事過去一覧検索HOME

スレッド

└◇1213:
Re:コンパイルできない [石原 守] 07/18 13:11

 └◇1214:Re[2]:コンパイルできない [hisa] 07/18 13:22
  ├◇1215:Re[3]:コンパイルできない [tDB] 07/18 13:38
  │└◇1216:Re[4]:コンパイルできない [hisa] 07/18 13:49
  │ └◇1217:Re[5]:コンパイルできない [tDB] 07/18 14:09
  └◇1218:Re[3]:コンパイルできない [飯島 徹] 07/18 16:26<-last


1213● Re:コンパイルできない[ 石原 守 ] 2014 07/18 13:11
\usepackage[dvips]{amsmath,amssymb,amscd,ascmac,theorem,rsfs,emath,emathEy,emathPh,hako,color}
は
\usepackage[dvips]{emathPh}
\usepackage{emathEy,hako}
くらいで大丈夫でしょうか

あと
! LaTeX Error: File `makerobust.sty' not found.
が気になります。TeXが古すぎて存在しないのでしょうか。
飯島さんのアドバイス通りシステムを新しいものに更新した方がよいと思います。

コメントを書く(引用) | スレッド一覧


1214● Re[2]:コンパイルできない[ hisa ] 2014 07/18 13:22
> \usepackage[dvips]{amsmath,amssymb,amscd,ascmac,theorem,rsfs,emath,emathEy,emathPh,hako,color}
> は
> \usepackage[dvips]{emathPh}
> \usepackage{emathEy,hako}
> くらいで大丈夫でしょうか

試してみましたが、下記のエラーが出ました。更新するしかないのか…


! LaTeX Error: File `makerobust.sty' not found.

> 飯島さんのアドバイス通りシステムを新しいものに更新した方がよいと思います。


更新するためのおすすめの方法はどのようなものでしょうか?
検索してみましたが、どれが良いのか分からず…
コメントを書く(引用) | スレッド一覧


1215● Re[3]:コンパイルできない[ tDB ] 2014 07/18 13:38
> 試してみましたが、下記のエラーが出ました。更新するしかないのか…

> ! LaTeX Error: File `makerobust.sty' not found.

emath.sty の 146行目でしょうか,
\RequirePackage{makerobust}%
という行があります。この行の先頭に
%
1文字を付けてコメント文にすれば,
とりあえず回避できます。
コメントを書く(引用) | スレッド一覧


1216● Re[4]:コンパイルできない[ hisa ] 2014 07/18 13:49
> ! LaTeX Error: File `makerobust.sty' not found.
 
> emath.sty の 146行目でしょうか,
> \RequirePackage{makerobust}%
> という行があります。この行の先頭に
> %
> 1文字を付けてコメント文にすれば,
> とりあえず回避できます。

まずemath.sty の 146行目というのが分からないです。
コメントを書く(引用) | スレッド一覧


1217● Re[5]:コンパイルできない[ tDB ] 2014 07/18 14:09
> まずemath.sty の 146行目というのが分からないです。

emath.sty のバージョンによって異なります。
エディタで emath.sty を開き
    makerobust
を検索語に指定して探します。
コメントを書く(引用) | スレッド一覧


1218● Re[3]:コンパイルできない[ 飯島 徹 ] 2014 07/18 16:26
>>1215 でtDBさんが提示されている方法は,
あくまで対症療法でしかなく根本的な解決にはなりません.
emathがアップデートされた時など忘れずに同様の処置をしなければなりませんし,
他に問題が起こらないとも限りません.
TeXに限らずソフトウェアは特別な理由がない限り常に最新の状態を心がけるべきでしょう.

TeXのインストールに関しては「TeX Wiki」に載っていますし,
http://oku.edu.mie-u.ac.jp/~okumura/texwiki/?Microsoft%20Windows#vb660ba1
わからなければ「TeXフォーラム」で質問もできます.
http://oku.edu.mie-u.ac.jp/tex/
TeXの更新をおすすめします.

これ以上は混乱の因になるかもしれませんので引っ込みます.
TeXのインストールに関してはここで質問をするより,上記の「TeXフォーラム」で
質問したほうがよいでしょう.

# OSがWindows XPなのではないかという不安が…(´・ω・`)
コメントを書く(引用) | スレッド一覧

CGIROOM